Chewed up primer sliders

This forum is for links to threads that offer a definitive fix for a specific Load Master problem. Please post each link separately with a portion of a message that describes the problem or fix. If you want to discuss the issues further, please do so in the original threads.

Moderator: darwin

User avatar
darwin
Site Admin
Posts: 1955
Joined: Mon Jan 28, 2008 8:11 am
Location: Central Indiana

Chewed up primer sliders

Postby darwin » Thu Feb 04, 2010 8:14 am

http://forums.loadmastervideos.com/foru ... .php?t=253

Greetings....I just found this forum from a link on the castboolit forum (a great place). My 10 year old LM is running like a train now, and I have developed a lot of fixes and rigs to keep it that way. I guess the most frequent problem I have had is primer sliders getting chewed up. I think most primer system problems can be traced to improper die adjustment. Dies set too low and limiting main ram travel. Then you end up cranking the adjuster lower, and the primer ram won't retract far enough before the shell plate moves around. Something like that anyway. One thing I have been doing for a long time is putting a decap only die in the first station, and sizing at the primer station. This holds the case firmly in place during primer insertion. I still get an occasional inverted primer, maybe one in 300-400. I have several fixes that I have come up with on my own that you guys probably could have helped me with and saved me time and aggrivation. I have occasionaly cussed my Loadmaster, and called it a "Rube Goldburg" device, but it is running fine for now. I will review your stuff and learn what I can....

Return to “Load Master - Major Fixes”

Who is online

Users browsing this forum: No registered users and 1 guest